Library Error

Ezekiel Oct 07, 2013 08:18PM EDT

Hello.

I just borrowed a book from the King County Library System. I read the book for about an hour or so, then closed Blio. After a few minutes, I started the program again and tried to open my borrowed book. It said, "An error occurred when displaying this book."

What should I do?

Please help...I still have 22 days to read this book but I'm sucked in already!

Up 7 Rated Down
Bob Oct 08, 2013 08:09AM EDT Blio Support Support Agent

It sounds like a corrupt installation. Typically if the book is working and then this happens, it means something has changed with the DRM component.

There are two options, we can do a remote session or you can try the auto repair utility.

Download the repair tool, or provide a phone number to reach you, to get started

If you would like to use the repair tool, please make sure to allow this file in your antivirus program as it is unlabeled and will likely be flagged as an unknown or a virus. Launch the EXE file and say yes to the user account control pop up and follow the steps on your screen.

After downloading, it is IMPERATIVE that you right click the exe file and select “Run as Administrator” and then say yet to the pop up. Not doing this will result in an error message and a failed uninstall/reinstall.

If you see the following image on the command prompt when running the tool, close the script and rerun it as admin:
FAILED

Up 6 Rated Down
Marian Wynn Oct 09, 2013 12:28PM EDT
If you download the repair tool, be patient. It looks like it isn't doing anything but it is. The "black" command window is something I haven't seen in years. It took my repair between 5 - 10 minutes to complete.

After you answer Y for Yes I opened this with administrator permission, you will see text that says something about Out Parameters and maybe something about instance of _PARAMETERS and ReturnValue = 0. I assume that is a good thing. Just wait because the next question is something about what kind of computer you have, 1) HP, 2) DELL, 3) OTHER. Answer this question with the appropriate number and wait again. The window will pop up from time to time with other cryptic messages. Wait for the final statement which is "Press enter to exit."

Unfortunately for me --- the same error occurred again.

ATTENTION An error has occurred while displaying this book.
Up 2 Rated Down
Bob Oct 09, 2013 12:31PM EDT Blio Support Support Agent

Marian,
I want to first apologize for how crude this tool is. I actually build it using CMD line variables (mainly because it lets me handle so many edge case setup scenarios). I’m trying to get this functionality hooked into the installer (some installers will give you repair options if the app is already installed).

As for the still getting the error, this usually indicates that there is actually a problem with the book file or the network connection.

What was the title of the book you had trouble with? I’d like to take a look on my end to see if it is something I can fix up.

Up 1 Rated Down
Marian Wynn Oct 09, 2013 01:10PM EDT
Hi Alex:

The Lost Symbol by Dan Brown

While I was waiting, I deleted the book, then ran the repair tool again, then downloaded the book again. The error still occurs. There are no other errors. The play ready procedure seems fine and the licence appears okay too. The book opens where on the page that I last read and after about 30 seconds the error: ATTENTION An error occurred while displaying this book. The sample books do not appear to have this error.

PS: I was going to check this book back in and recheck it out. It appears that there is no option to return a book before it's original due date. Oops!

I have some fast readers here at our library. Will this be an option soon?
Up 8 Rated Down
Bob Oct 09, 2013 01:15PM EDT Blio Support Support Agent

I took a look at the Lost Symbol ISBN 9780385534505 and it appears to be working for me. Any chance we could try a remote session so I can see what is going on with that machine?

To address the early return function, this is a known issue and we are waiting to push some changes to the server but the function should be out pretty soon.

Up 4 Rated Down
Marian Wynn Oct 10, 2013 06:41AM EDT
Hi Alex:

Remote session is fine. Let me know what to do from my end.
Up 2 Rated Down
Bob Oct 10, 2013 06:44AM EDT Blio Support Support Agent

I responded to the email you sent in and we can do the remote session and take a look.

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)

Contact Us